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1 Introduction  
___________________________________________________________________ 
 
 
 
MALÅ MIRASoft is the data acquisition software dedicated to the MALÅ MIRA (MALÅ Imaging Radar 
Array) system from MALÅ Geoscience. MIRASoft acquires data from the MALÅ ProEx control unit 
together with the array option. As a Windows™ based software MIRASoft gives you an easy-to-use 
user interface, file management, printing and other key features. Each measurement and associated 
settings are stored in files. Filtering can be performed with the measurement or as post-processing. 
The MIRASoft software supports Total Station, GPS logging and multiple markers during 
measurement. All radargrams can be printed as such, or post processed by other software (rSlicer, 
Radexplorer). 
 
 

 
 
We at MALÅ Geoscience welcome comments from you concerning your experiences in using this 
equipment, as well as your impressions of this manual. Please take the time to read through the 
assembly instructions carefully and address any questions or suggestions to the following: 
 
Main Office:                         
MALÅ Geoscience                 
Skolgatan 11                           
S-930 70 Malå                         
Sweden                                                        
 
Phone:  +46 953 345 50          
Fax:      +46 953 345 67                         
E-mail: sales@malags.com       
                                  
 
Technical support issues can be sent to: support@malags.se  
 
Information about the products from MALÅ Geoscience is also available on Internet: 
http://www.malags.com 

mailto:sales@malags.com
mailto:support@malags.se
http://www.malags.com/
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2 Installation 
___________________________________________________________________ 
 
 
The MIRASoft software is delivered to you on an installation CD. It contains a set of program files that 
will be installed once you run the Setup.exe file.  
 
Note! The WINPCAP library (by running “WinPcap_4_0_1.exe”) has to be installed first of all and then 
the program (which is done by running “Setup.exe”). 
 
When you double click on the setup files (WinPcap_4_0_1.exe or Setup.exe) you will enter an 
installation wizard that will guide you through the rest of the installation process. 
 
Note! If you are doing an upgrade installation of MIRASoft it is recommended to uninstall the previous 
version of MIRASoft first. This is easiest from the Windows Control Panel -> Add/Remove programs.  
 
 

2.1 Computer requirements 
 
The software runs on Windows XP, VISTA or Windows 7 (32 or 64 bits) and requires minimum 1GB of 
RAM. It’s recommended to have a sufficient efficient computer (CPU 1GHz or higher) since the 
displaying and storage of the data can be a rather heavy task. Horizontal resolution of the screen is 
limited to 3000 pixels. The MIRA system collects approximately 130kb data/m2, if using a 400 MHz 
antenna and the following settings: 400 samples, 16 channels, 8 cm between the channels, and a 
trace distance of 8 cm.  
 
It’s also recommended to switch off all unnecessary communications links such as blue-tooth, 
wireless, infrared or any other present line. Some Ethernet cards will cause conflict when the wireless 
link is enabled. Ethernet packets lost is not acceptable in this system, therefore wireless 
communication cannot be used, ethernet cable and Ethernet card must be of good quality. 
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3 Using the MIRASoft 
___________________________________________________________________ 

 

3.1 Overview 
 
Software for the MIRA system comes in two packages; the acquisition software, MIRASoft and the 
processing and interpretation package, rSlicer. Both are designed to work with the MIRATM system 
(MALÅ Imaging Radar Array).  
 
This manual deals with the acquisition package, the MIRASoft, which enables the operator to freely 
set up the radar antenna array system and collect data and save it to suitable rSlicer format. During 
data collection it’s also possible to view one radargram and traces from all channels. More information 
regarding rSlicer is found in the Operating manual rSlicer. 
 
The user interface of MIRASoft is developed to be easy to handle during field work so the most 
important options are governed by the function buttons, F1 to F12.  
 
The following definitions are used: 
 
Trace= The recorded radar signal from one channel at one point. An envelope built up by a certain 
number of samples.  
Point distance = Distance between each trace collected for all individual channels.  
Sample= Instant, digital value of recorded radar signal at one specific time.  
Stacks= Number of averages for each trace 
Swath= One complete profile line including all channels in the array. The coverage for every swath 
depends on the individual channel spacing times the number of channels. 
 
 

3.2. First start 
 
When the programme is started for the first time, the contact between the ProEx control unit and the 
MIRASoft may not be established directly. In this case select the option Tools -> Link Options and 
choose the correct Ethernet card to connect to the control unit. Then press F2 to connect to the control 
unit. 
 

      
 
Note! Switch off all other communications links such as blue-tooth, wireless, infrared or any other 
present line. Some Ethernet cards will cause conflict when the wireless link is enabled. 
 
After this it is convenient to check and define the Channel Configurations (in which sequence the 
antennas are going to measure) and the Channels Order (the position of the different antenna 
elements in the antenna array). For more information see Chapter 4. These two must be defined 
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according to the used antenna array in the MIRA system to give correct end results. Once these two 
has been defined, they can be used in other projects, measured with the same antenna array and in 
the same mode. 
 
MIRASoft uses two system files for defining the array configuration: “ch_order.cfb” for the Channels 
order and “channels.cfa” for the Channel Configurations. These files are created in separate dialogs 
and are stored in the user’s Application Data directory.  
 
When the Channel Configuration and Channels order are appropriate, the following steps are made 
prior measurement start: 
 

 Create New Project (File -> Create New Project). To define a working project directory and 
name see Chapter 7. The project name is displayed below the main screen of MIRASoft. 
Project Header File with extension “.mira” is also created. 

 
Note! It is good practice to create a separate directory for every project so that all positioning 
settings, tie-in-points etc. are saved in the same place.  

 
 GPS or Total Station settings (Tools -> Positioning Parameters). To define correct 

communication setting between the MIRASoft and the positioning system and to set a centre-
point of the investigation area. See Chapter 5. 

 Tie in points (Tools -> Tie in points). Points surveyed (positioned) as reference for each total 
station position See Chapter 6. 

 Line and Point Features (Tools -> Insert points and lines). To position features, such as 
roads, trees, houses in the investigation area. These features can then be displayed, as a 
base map, together with the radar data in the processing software rSlicer. See Chapter 6.  

 Measurement settings (Tools -> Measurement Parameters). To define measurement point 
interval, sampling frequency etc. See Chapter 7. 

 Time zero (Tools -> Measurement Parameters). To set a correct time zero for the all array 
channels used. See Chapter 7. 

 Start measurement (F3). See Chapter 7.  
 

3.3 Main menus 
 
Below, in Fig. 3.1, the main view of the software is shown. The fast keys in the upper left corner give 

easy access to the main functions  ; 
 

o F1 Help 
o F2 Connect to Control unit 
o F3 Start measurement with previous parameters 
o F5 Stop/Pause measurement 
o F6 Restart measurements 
o F7 Open existing swath 
o F8 Tie in points 
o F9 Features 
o F10 Positioning parameters 
o F11 and F12 Decrease and Increase contrast. The effect of changing the contrast with the 

contrast control is, somewhat similar to a change in the gain function, but much easier and 
faster to do. 

 
Normally communication with the ProEx control unit is established when the software is started. This is 
indicated by a red coloured arrow for F3. 
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Figure 3.1 The main screen and menus at start-up. 
 

3.3.1 File menu 

The File menu gives access to the usual file handling, 
create new project, open a project to continue 
measurement, open existing swath, save files for rSlicer 
(processing software). There’s also quick selection for 
recent opened files. 
 

  

3.3.2 Tools menu 

 

The Tools menu gives access to menus for Link Options, MIRA 
CU Options, Measurement Parameters, Data View Options, 
Palette, Filter, Markers, Wheel calibration, Channel Configuration 
and Order, Positioning parameters, Tie in Points and Points-Line 
menu. 
 
Information on Channel Configuration and Order, Positioning 
Parameters and Tie in points and Points/Lines and Measurement 
Parameters is found in Chapter 4, 5 , 6 and 7 respectively. 
Otherwise see below. 
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In the Link Options the correct Ethernet 
Interface is chosen. 

 
 

 
In the MIRA CU options there are 3 
selections to select, by default none are 
seleted.  
 
By selecting Missed Traces Mode, the system 
will write zero traces to the data file, 
whenever the survey speed is too high for the 
system. This is done without any data passed 
from the control unit to the PC.  
 
If Bi-directional Mode is selected, the system 
collects data in both directions and the 
distance shown is the total travelled, 
backward and forward.  

 
 

 
In the Data View option pop-up menu the vertical 
scale can be set to Time or Depth together with 
the first arrival and the ground velocity to use.  
 
The distance units available are meters and feet.  
 
 

 
 
 
In the Palette manager the palette of the active radargram can be 
viewed, altered, loaded, or saved.  
 
Double clicking on a specific "colour box" opens a Windows colour 
dialog and a new colour can be chosen. 
 
One single right-click on a "colour box" makes it activated, which 
means that it will be used when interpolating the palette. Another 
single right-click on the same "colour box" deactivates it. When 
interpolating the palette is recalculated depending on the colours in 
the activated "colour boxes". OK closes the Palette Manager and 
applies the new palette to the radargram. 
 
The palette can be saved with a freely given name and in a freely 
specified directory with the file extension ".pal". To open a saved 
palette click the Open Palette button and load the selected palette. 
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The functionality of the Filter Manager is quite 
straightforward. Choose a filter and click either the Add or 
the Remove button and the chosen filter will be either 
removed or applied. It is also possible to double click the 
filter to be added. By “drag and drop” the order of the filters 
in the Applied list can be altered without removing and 
applying.  
 
To the left, there is a list of available filters and to the right 
the list of the applied filters is shown. See also Appendix 1 
for a short explanation of the different filters. 

 
 
MIRASoft supports a multiple Marker function during measurement. 
Up to 9 markers of different type and colour can be configured in the 
marker dialog. The nine numerical keys 1-9 on the keyboard are 
predefined as marker keys. Each key needs to be enabled by checking 
the white box to the right of each key number. A new colour can be 
selected by a double click on the colour box. Any comment for each 
marker type can be entered in the comments field. 
 
If markers keys are pressed during the measurement, information will 
be saved in a text file with the extension *.mrk. The first line contains 
information about the header version. Following in the file is three 
columns (space-separated) with trace number, sample number, 
marker type (1-9). 

 
Note! Markers can also be set with the Remote Control by pressing the marker button. Markers set in 
this way will always be of type 1. 
 
 
 
To perform a Wheel calibration, start with 
connecting the control unit and the wheel to 
calibrate/use, switch the control unit on. Choose 
Wheel Calibration to open the Wheels dialog.  
 

 
 
Note! The precision of the encoder wheel is not infinite and depending on several factors as; the 
measurement surface, the pressure applied on the wheel and possible wear. If you are unsure of the 
encoder wheel precision a re-calibration should be made. 
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If a new calibration is needed, press New  
and follow the instructions in the New Wheel dialog (the 
START button will turn into a STOP button when the 
calibration is started). Type the desired name of the 
calibration in the Name edit box. If the number of ticks/ft 
for the wheel is known this can be entered manually. OK 
saves the new wheel calibration in the control unit 
memory. 

Wheel calibrations can also be deleted in the Wheel 
dialog by marking the calibration and the pressing 
Delete.  

 

3.3.3 Other options in the Main View window 

 
The workload indicator  in the toolbar shows how much the system (GPR and 
PC) is loaded. The indicator goes from green on the left side, to yellow and finally red on the right side 
and should not more than occasionally turn red.  
 

 indicates how well the positioning is carried out, more can be 
read in Chapter 5. The other three fields in the Main view shows: 
 

1) The different data channels. By clicking or using the arrow buttons the data view toggles 
between the channels.  

2) The data window. 
3) Trace view. 

 
These three fields can not be changed, but are optimized to give the best view during data collection. 
 

 

1 

2 

3 
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4 Channel configuration and orders menu 
___________________________________________________________________ 
 
 

4.1 Channel configuration 
 
In the channel configuration menu the operator selects how the radar array should be set up to collect 
data. The user defines a sequence of firing the antennas and this sequence is repeated for every time 
the trig condition set becomes true, normally every time a new acquisition point is reached along the 
swath.  
 
A standard channel configuration for a 16-channel antenna array is shown in the picture below. This is 
also provided within the software at purchase.  
 
The maximum number of sequences, which can be defined, is 16 in one firing table.. 
 
Note! It’s not possible to switch a receiver between two transmitters in the sequence in one firing table 
(in other words a receiver can not be repeated in one firing table). Doing so will result in an error 
massages. Array-operation requires, however, each receiver switched between at least two 
transmitters and therefore two sets of firing tables are to be defined for one sequence. This cross-talk 
generates the dense profile distance characteristic in the MIRA system. 
 
In the figure below the Channel configuration menu is shown. The number of available channels is 
dependent on how the system was defined at time of purchase. In the example a standard 16 channel 
system is activated, 9 transmitters and 8 receivers. Note that the system can only be set up to handle 
one receiver per transmitter antenna in each “firing” table. 
 

 
 

 
Start the procedure by selecting the transmitter 1 and receiver 1. Once this is done the button “Add” is 
pressed for the first firing table. The user repeats this until the whole sequence for the array is defined. 
 
Note! Channel configurations can be saved and loaded again in so called *.cfa-files. Chose the option 
Save As and then Load from file to use the saved configurations. 
 

Firing table 1 

Firing table 2 
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It is important to keep in mind that each transmitter can be activated every 10 microsecond (5 
microseconds for 2MHz MIRA). The software will automatically add empty sequences if the operator 
does not meet these conditions. 
 
After finishing the channel configuration, the operator presses the OK button and the configuration is 
saved in the internal memory as well as in the configuration file, “channels.cfa”. The configuration file 
can be viewed with a text editor.  
 
The configuration is transferred to the control unit when the measurement is started or when the traces 
are viewed in the measurement setup menu. 
 
 
Note!  

1) Receivers can not be repeated inside one table. 
2) Transmitters can be repeated but it has to be 9 sequences in-between, if there are less than 9 

sequences empty sequences will automatically be added; 
3) If it is less than 10 sequences in a table empty sequences will be added automatically to 

maintain a 100 KHz repetition rate; 
4) If you want maximise speed, use only the first table and left the second table empty; 
5) In the list the string “<empty>” can be seen. This is an empty sequence that granted safe rest 

time for transmitters (10 microseconds for 100 KHz antennas). One can not delete them (even 
if one tries). The user can optimize transmitter’s position to minimize number of the empty 
sequences and by that faster measurement will be possible. 

 
 

4.2 Channel order 
 
The Channel order option defines the location of each channel and which channels to be included in 
the rSlicer processing. The Cannel order is used by both MIRASoft and rSlicer to keep track of the 
antenna array position.  
 
A standard channel configuration for a 16-channel 400 MHz antenna array is shown in the picture 
below. This is also provided with the software at purchase. 
 
To set the Channels Order table the following steps are done:  
 

 Select “Tools -> Channels Order” (see below); 
 One has to enter as many channels as it exists in the Channel Configurations table (see 

above). If fewer is entered, the OK option does not work, only the CANCEL option. If more 
channels than necessary are entered they will be zeroed. 

 Table field must set to 1 or 2 according to the firing table. Configuration field must be set to 
TN1RN2 where N1 and N2 are numbers, for example T1R1 or T11R13. X-Shift and Y-Shift 
are antennas coordinates in meters in the special MIRA coordinate system, where the Total 
Station prism or GPS receiver is located in the 0/0-point, the X-axis is parallel with Array and 
the Y-axis is in the measurement direction. 

 Mark the channels to be included for the rSlicer processing, in the Processing column. 
 
In the configuration below the Total station prism or GPS receiver is located on the first measurement 
profile, between T1 and R1. This gives an X-shift value of 0 m. See corresponding antenna array (400 
MHz) to this Channels order in Fig. 4.1.  
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Fig. 4.1. The antenna array with 9 transmitter antennas and 8 receiver antennas, gives for a 400 MHz 
system a distance of 8 cm between the different channels (measured profiles) and a measurement 
point (Y-shift) 35 cm from the 0/0-point, which is indicated with a red dot. The TS Prism or GPS rover 
antenna is placed on this red dot.  
 
 
Note! Channel orders can be saved and loaded again in so called *.cfb-files. Chose the option Save 
As and then Load from file to use the saved order. 
 
After finishing the channel order, the operator presses the OK button and the configuration is saved in 
the internal memory as well as in the channel order configuration file, “ch_order.cfb”. The configuration 
file can be viewed with a text editor.  
 

X 

Y 
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5 Settings of Positioning Parameters 
___________________________________________________________________ 
 
 
A GPS or a Total Station is essential to position the antenna array box during measurements. The 
system used needs to have a centimetre accuracy of the position data (RTK-GPS only) otherwise the 
end-result will not be satisfying. The initialization of the GPS or Total Station is done according to the 
operating manuals of the system used. In this chapter the settings for the MIRA system is explained.  
 
Both the Total station and the GPS equipment are connected to the computer used for data collection 
via the serial port. See the MIRA System manual for more information.  
 
The settings for both GPS and Total station parameters are found in Tools -> Positioning parameters 
 

 
 
Note! For both the Total Station and GPS solution it is essential that the measurement swaths start 
and stop with a correct and reliable collected positioning data.  
 

5.1 GPS settings 
 
MIRASoft can read GPS data from any GPS receiver that supports output of data with the NMEA 
(0183 GGA) or TSIP communication protocols. The GPS logging is saved in a GPS log file, the file 
name can be: <first profile name>.cor, <first profile name>.fri or <first profile name>.utm, in which GPS 
data are written together with the corresponding trace number. Format of these files is described on 
the next page. 
 
To change the GPS communication settings, choose Tools -> Positioning Parameters. Make sure that 
the GPS choice in marked in the Positioning parameters pop-up window.  
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Here the output file format can be changed 
together with communication settings.  
 
Important in the GPS Parameters window is the 
option Set the centre of the local coordinate 
system. This is necessary to get the correct local 
coordinates in the *.POS file for rSlicer. 
 
This command, positions one point in the 
investigation area and uses this information for a 
correct coordinate transformation to the *.POS 
files.  
 
Note! This can only be done once in each project 
and the measurements can not be started unless 
this is done.  

 

 
Output file format 
Use this selection box to choose between the three different position output formats: GroundVision 
Standard (*.cor), WSKTRANS (*.fri) and UTM coordinates (*.utm)  
 
GroundVision Standard 
This data file format contains the following information: trace number, date, latitude, longitude, height 
above mean sea level, and HDOP. HDOP is a theoretical measure of the accuracy in the horizontal 
coordinates based on the positions of the available GPS satellites. A lower value indicates better 
accuracy. The date and time is expressed in Greenwich time zone. The following is an excerpt of a 
*.cor file (Trace# date time latitude N longitude E “height above MSL” M HDOP): 
 
105  2000-9-13  11:9:33  65.18164955141  N  18.75051193218  W  357.26  M  1.454542 
106  2000-9-13  11:9:34  65.18164955141  N  18.75051193218  W  357.26  M  1.454657 
107  2000-9-13  11:9:35  65.18164955141  N  18.75051193218  W  357.26  M  1.454898 
 
WSKTrans free format 
The WSKTrans free format is a special format compatible with WSKTrans, a coordinate transformation 
software from the Norwegian land survey. The format is (space separated): 
EU89-Geodetisk,P,G,HE 
“Trace #” latitude longitude “height above ellipsoid” 
 
The UTM 
The UTM coordinates format contains coordinates in the UTM grid calculated from the latitude and 
longitude data from the GPS receiver. The transformation is made using Redfearn’s formulas. GV 
uses a public domain implementation of these contained in the class KCoordinateTransformer. Note! 
MALÅ Geoscience takes no responsibility in the accuracy of this transformation. The format is (tab 
separated): 
 
“Trace #”  northing  easting  “height above MSL”  “UTM zone” 
 
 
Communications settings 
Normally the default settings should work but if there is no contact with the GPS receiver use these 
options to make sure that the communications settings match those of the receiver. 
 
Baud rate, Parity, Data bits, and Stop bits  
These are serial port communication settings, which must match those of the GPS receiver, default 
4800, 0, 8 and 1 respectively. 
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Com. Port 
This setting determines witch serial port on the computer to use for the GPS receiver. The default 
selection is the first serial port (COM 1). 
 
Protocol  
Selects witch communication protocol to use. NMEA (0183, GGA sentence) is a standard protocol that 
should work with most GPS receivers. TSIP is a protocol supported by Trimble GPS units. The default 
selection is NMEA. 
 
 
 
When all settings are done, and the communication functions two extra field is seen in the Tool Bar:  
 

  Toolbar with GPS info before measurement 
 
The first field will show the distance of the measurements, and it counts from the GPS coordinates in 
the local coordinate system. The second field is a quality field, it is ok if it shows values >0 and <8. 
Note! However, to have sufficient accuracy for the MIRA system, this value should stay as 4 and 
nothing else during the whole investigation, indicating RTK GPS quality.  
 
The second field values are in detail: 
 
        0 = invalid 

                     1 = GPS fix (SPS) 

                     2 = DGPS fix 

                     3 = PPS fix 

                     4 = Real Time Kinematic 

                     5 = Float RTK 

                     6 = Estimated (dead reckoning) 

                     7 = Manual input mode 

                     8 = Simulation mode 

                     66 = no contact with the GPS . 

 

 
The toolbar with GPS information under measurements looks like this: 
  

 
 
If the second field, the quality field, is not equal to 4 (RTK mode) then both fields become red. 
 
The idea of these fields is that one does not need to control the GPS position under measurement, but 
one has to control the quality of the GPS data and distance from GPS (this distance must be 
approximately equal to the distance given by the encoder wheel, if not - one has to check wheel 
calibration, contacts etc.) 
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5.2 Total Station settings 
 
To change the Total Station communication settings, choose Tools -> Positioning Parameters. Make 
sure that the Total Station choice in marked in the Positioning parameters pop-up window.  
 
The COM-port settings are explained in Chapter 
5.1 above. 
 
Note! The Set centre of the local coordinate 
system is not used when working with a Total 
station.  
 
 

 
 
As this is done, and the communication functions an extra field is seen in the Tool Bar:  
 

 
 
This field shows the measurement distance calculated by the Total station during measurement and 
this figure is to be compared with the distance given by the encoder wheel. The TS field will start to 

blink red if there is no or a bad contact with the Total Station during the 
measurements. Decrease the measurement speed or stop for a while and check if there is a free sight 
between the Total station and the prism on the antenna array.  
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6 Tie in points and Features 
___________________________________________________________________ 

 

6.1 Tie in points 
 
Tie in points are only used when positioning of the antenna array is done with a Total Station. Points 
around the investigation area are positioned, to create a reference if the Total Station needs to be 
moved during the investigation.  
 
At least three points have to be established for the first Total Station position. When the Total Station 
is moved, the same three points are positioned again, to tie in the new Total Station position and by 
that measurement swaths in the investigation area. All measurement files will then end with "G02". 
 
The rSlicer software uses the coordinate system associated with the first TS position as reference. 
 
Open the Tie in point’s pop-up window (Tools -> Tie in Points) and as the prism is placed in the right 
position at the tie in point, press measure to read the correct coordinates. The point can be named 
freely, by typing in the Tie-in point ID field.  
 

 
 
When all tie in points are positioned, press SAVE and EXIT.  
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6.2 Line and point Features 
 
With the option Lines and points (Tools -> Insert points and Lines) straight lines and points can be 
created to mark roads, trees, houses etc in and around the investigation area. 
 
The prism (for the Total station) or the rover antenna (for the GPS) is located on the lines or objects to 
mark, while the operator of the software presses Start a Line, Stop a Line or Set a Point.  
 
Note! If a Total station is used, two persons are needed, one to move the prism and the other to press 
"Start a Line", "Stop the Line" and "Set a Point" at the computer. If a GPS is used, one person is 
enough. The investigation vehicle (with PC, antenna array, GPS antenna) can be moved to the 
wanted points or lines or only the PC with MIRASoft and a connected GPS. 
 
 

 
 
Press OK to save the mapped features.  
 
Note! In the file FCODE.txt (located in the MIRA Soft directory) Points and Lines can be defined. This 
FCODES.txt file is also used by the processing software rSlicer.  
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7  Data Acquisition 
___________________________________________________________________ 
 
 
In short a measurement is carried out in the following steps. More information on each point is found in 
this Chapter:  
 

 Ensure that the Control Unit is ON and it is properly connected to the computer. 
 Ensure that the Control Unit connected properly to the antennas. 
 The program connects to the Control Unit automatically if you start it after the Control Unit is 

ON. If you switch on the Control Unit after the program, then you need to press F2 to connect 
to the Control Unit manually. If the connection is established the F3 button will become red. If 
the connection isn’t established even after pressing F2, this may be due to low battery level or 
disconnected cables. 

 Create New Project, by choosing File -> Create New Project. Choose the location where you 
want your project files to be saved, and give a name (better to create a separate directory for 
the project and the default position for your data files will be inside this directory). Press Save. 

 

 
 

 Press the Start file button (F3) or NEW on the Remote Control. The New Profile dialog opens 
(see below). 

 In the New Profile dialog enter the file name to use. Press Parameter to select the antenna 
and trigger source to use. Press the Settings button to open the Measurement Settings dialog; 

 In the Measurement Settings Dialog the Time Zero (first arrival) is found for the different 
channels; 

 Close the dialogs by pressing OK when all settings are made; 
 Select Start from the New Profile dialog. 
 Select Stop by pressing F5 to stop the measurement or STOP on the Remote Control. 

 
NOTE! When using the Remote Control the measurements starts directly and no new measurement 
settings can be made. For the first measurement line it is always best to check all measurement 
settings, so that they are correct and then use the Remote Control for the rest of the measurement 
lines in the same project.  
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Data collection is initiated by pressing the “Start 
file” button (F3).  
 
 
 
 
 
 
 
 
Press Parameters to reach the Parameters pop-
up window. In this menu the trig source (time, 
manual or wheel) and a pre-selection of antenna 
parameters can be chosen. 

 
 

 
 

In order to view the radar signal and to set the 
acquisition parameters more in detail, press the 
“Settings” button. This leads to Measurement 
settings menu. 
 
In the Measurement settings menu the operator 
sets radar parameters such as sampling 
frequency, stacks, number of samples etc.  
 
Detailed description of these parameters as well 
as information on time zero setting is found 
below.  
 

7.1 Time zero setting 
 
The most important difference compared to normal, single channel operations, is the time zero setting. 
Since there’s no way to guarantee that all channels have the same lead time in electronics and cables, 
the time zero have to be set so that it safely register the first arrival of all the used channels. In order to 
help the operator doing this, a channel number choice is found close to the “Search Time Zero” button. 
This channel number defines the channel for which the time zero is searched for and set. The 
“earliest” channel, in other words the channel where the time zero appears first, should be used during 
the search.  
 
When pressing the “Test and Search for Time Zero” button a window showing traces from all the 
channels are showed, see fig.5.1 below.  
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Figure 5.1 Test for time zero settings.  
 
To fix an inappropriate time zero setting, close the window and go back to the previous menu and 
either change the signal manually or select another channel and repeat the search. In fig 5.2 below a 
correct set time zero is shown. Now the first arrival of all channels is clearly distinguished and 
approximately at the same level for each channel.  
 

 
 
Figure 5.2 Test for time zero settings.  
 
 

7.2 Measurements settings 
 
In the Measurement settings dialog the following parameters are found: 
 
Adjusting the Sampling Frequency and/or the Number of Samples controls the Time Window. 
 

Sampling Frequency shall be set to approximately 10 times the antenna frequency. If the trace view 
only displays a straight line, make sure that the transmitter is turned on and is correctly connected. 
Does not that help; try the Search for Time Zero button. 
 
Number of Samples shall be set to a value near 500 for the best performance. A higher number 
increase the total measured time window but slow down the measuring speed and creates larger data 
files.  
 
Alter the Trig Interval (the point distance) if the default settings are not appropriate. Make sure that 
the Antenna Separation is correct. Otherwise, the calculation of the zero for the vertical scale will be 
incorrect. 
 
The number of Stacks is equal to the number of times that each sample is measured and averaged 
over. 
 
Note! Whenever possible, it’s always recommended to use stacking. In spite of the high performance 
of the MIRA systems, this averaging and the selected point distance puts some limits on the maximum 
survey speed. Assuming 200 kHz repetition rate and 8 cm point distance and 350 samples, the 
maximal survey speeds are listed below, at different number of averaging (number of stacks). 
 

Number of 
averages (stacks) 

Resulting maximum 
survey speed, km/h 

1 75 
2 37 
4 19 
8 9 
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7.3 Measurement started and change of measurement line 
 
The measurement is started by pressing Start 
measurement. If no positioning data is found an 
alert will show up.  
 
The measurement can not be started if no 
positioning data for the first point is available, as 
the data can then not be used for any further 
processing.  
 

 
 

 
 
Once the data collection is started, the operator can select one of the channels to be displayed as a 
radargram in the main view. This is made from the Channel window at the left side of the Main view. A 
channel can be selected for the Profile View by a mouse click or with the arrow buttons. 
 
All traces from different channels are displayed simultaneously, for the current mouse position. See 
Fig. 5.3. This window shows the last trace under measurement. 
 
Note! No interpretation is possible during data collection. This means that data quality control is very 
important and most often the trace windows will provide the best solution to check this out during data 
acquisition. 
 

 
 
Figure 5.3 The MIRASoft Main view during data acquisition.  
 
When the measurement is started the workload bar is also seen on the main screen. This should be 
kept on green or green yellow, but not turn red more than occasionally: 
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Note! The Position Bar (GPS or TS in Fig. 5.3) will start to blink in red if there is something wrong with 
the connection to the Total Station or to the GPS receiver. Decrease measurement speed or stop and 
wait until the position data is ok again. For the different GPS error codes, see Chapter 5. 
 
If something goes wrong during measurement (wrong direction, wrong position etc.), the swath can be 
restarted by pressing F6 (Restart). The following dialog is shown: 
 

 
 
 
When the end of the swath is reached, stop the measurement by pressing F5 (Stop) or STOP on the 
Remote Control..  
 
Note! This should not be done unless the positioning bar is black, indicating a good position for the 
last trace in the file. Otherwise an alert will show up, with different options to either wait for a correct 
position or force a stop.  
 
Return to the start position of the swaths, press F3 (New profile) and then enter to start a new 
measurement or NEW on the Remote Control, and again check that the positioning data is in order.  
 
When all data swaths are collected, use File -> Save files for rSlicer to save the data and positioning 
files in a correct manner for the processing software rSlicer.  
 
 

7.4 Measurements in any direction 
 
Measurements with the MIRA system can be carried out in any direction as long as the TS prism is  
located so it is visible (constantly in line of sight) from the TS base station, for example on top of the 
carrier.  
 
Note! Measurements made with more or less straight lines will create a better end result than very 
curved lines.  
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When the prism location is decided, a Channels order is created to fit that set up. Note!  One must be 
careful when changes are made in the Channels Order so it is made correct, otherwise the positioning 
of the measured swaths will be incorrect as well as the end results. See Chapter 4.2.  
 
The advantage of the high prism position is that measurements can be carried out by one man (no 
need to adjust the self-tracking TS), and at the survey lines can be laid out freely (time-saving). 
However it should be noted that the distance from the TS prism to the antenna array should be less 
than approximately 2 m. If it is longer the off-set in the Channels order will be large, especially in 
curves, and by that the positioning in the end result. The disadvantage with high prism position is that 
position accuracy decreases if the ground is uneven. 
 
  

7.5 Measurements without Total Station or RTK GPS 
 
 
If measurements are going to be carried out without any positioning system (this is however not 
advisable) and the data are to be processed with rSlicer, the following instructions are to be followed. 
First of all mark the option “Without positioning” in the Positioning Parameters dialog (Tools -> 
Positioning parameters), the MIRASoft will automatically create a *.pos file for rSlicer when pressing 
F5 (stop of profile), based on the measuring wheel.  
 
 
Measurements in straight lines 
 
Note! The given distances below are applicable for a 16 channel 400 MHz array with 8 cm channel 
spacing. 
 

1. Measurements have to be made in straight lines. Mark the lines properly on the ground before 
start of the survey. 

 
2. The start position of the first swath is X=0 and Y=0. The Y coordinate will grow according to 

the encoder wheel, along the measured line.  
 

 
 

 

X 
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3. The 2nd swath starts at X= - or +1.28 m (16 channel spacings times 8 cm channel 
separations), depending on if the next swath is done left (-) or right (+) of the first one. To ease 
field work it is convenient to mark the position of channel 1 and 16 on the antenna box. And 
for the 2nd swath the channel 1 should be 8 cm apart (right) from the marked line for channel 
16 in the 1st swath (if 2nd measurement swath is done right of 1st ). The X figures are noted and 
then used to edit the created *.POS files, see point 6 below. 

 
 
 
 

 
 
                    First swath  X=0                  Second swath X=1.28           Third swath etc 
 

4. The third measurement accordingly X= 2.56 and so on.  
 

5. When pressing F5 (stop) for each swath, a *.POS file is created. This *POS file has only 2 
positions; Start and Stop. The Start position has coordinates: (Tracenumber, 0, 0, 0) and the 
Stop; (Tracenumber, 0, Ystop, 0), where Ystop is the profile length in meters (based on 
measurement wheel and number of traces). This *.POS file will be treated as a straight line in 
rSlicer.  

 
6. When a set of swats is made, as explained in point 3 and 4 above, the created *POS files has 

to be edited for each made swath. The X coordinate is found as  the second figure in the 
string; Trace, X, Y, Z. Note! If the second and following swaths were made to the left of the 1st 
use a minus sign. See example below. 

 
The first column in the *POS file gives the trace number and the second column the X-values (position 
of swath). The third column is the Y-value (coming from the length recording) and the last and forth 
the Z-value (the elevation, so this is set to 0).  
 
Below three *.POS files are shown, measured at position X=0, X=1.28 and X=2.56, for 13.2 m long 
swaths.  
 
 
UNITS:m 
1    0.000000    0.000000    0.000000 
164    00.00000    13.12000    0.000000 
 

 
UNITS:m 
1   1.280000    0.000000    0.000000 
165  1.28000    13.20000    0.000000 

 
UNITS:m 
1   2.560000    0.000000    0.000000 
165   2.56000    13.20000    0.000000 

 
Below three *.POS files are shown, measured at position X=0, X=-1.28 and X=-2.56 (the following 
swaths are made left of the 1st), for 13.2 m long swaths.  
 
 
UNITS:m 
1    0.000000    0.000000    0.000000 
164    00.00000    13.12000    0.000000 
 

 
UNITS:m 
1   -1.280000    0.000000    0.000000 
165  -1.28000    13.20000    0.000000 

 
UNITS:m 
1   -2.560000    0.000000    0.000000 
165   -2.56000    13.20000    0.000000 

 
 
Measurements in bent lines 
 
If measurements are to be carried out in a bent swath, then the measurement is started as usually, but 
in every bent point press for a marker (1 to 9). When the measurement is stopped (F5) a *.POS file is 
created with 5 positions (if one marker is set for one bend during measurement):  
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1. Start position, coordinates (Tracenumber, 0, 0, 0); 
2. Position before the bent point (Trace, 0, Ybp - 0.5, 0);  
3. Position of the bent point (marker): (Trace, 0, Ybp, 0) (where Ybp is the position in meters) 
4. Position after the bent point: (Trace, 0, Ybp + 0.5); 
5. Stop position, coordinates (Trace, 0, Ystop, 0) 

 
The swath can be opened in rSlicer and bends by moving the points 4 and 5 in the geometry edit 
option. 
 
 
Measurements with a simpler Total Station 
 
If the used Total Station can not communicate directly with the data collection computer, the 
measurements should be done without positioning (Tools -> Positioning parameters). The Start and 
Stop coordinates and the coordinates between them is read from the Total Station and noted and then 
placed in the *.POS file. 
 
Continue a Project 
 
When one wants to continue a closed project the project has to be opened (File -> Open Project). File 
Open Dialog is opened and the user can find and open Project Header File. When Project Header File 
is opened channel configuration and channel order from the last swath in this project are opened as 
well and the user can press F3 and continue create swaths for this project. 
 
Recreate a Project with the same name 
 
If the  user wants to start a project with the same name from the beginning he can choose File -> 
Create New Project and give same name in the same directory as the existing project. The message 
will come: ”<project name>.mira already exists. Do you want to replace it?”. If the user selects ”yes” 
then a new empty project header file with the same name will be created and the previous file will be 
saved as ”<project name>.mira_backup_NN” where NN is number from 00 to 99.  
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8 Files 
___________________________________________________________________ 
 
 
Data files names 
 
The  radar data file names (*.rd3 and *.rad) have following structure: 
 
<Project Name>_<Measurement number>_<Channel number>.<Extension> 
 
For example:    Field_033_A003.rd3 
 
 
Data files extensions 
 
The following files are created in MIRASoft in conjunction with a measurement: 
 
*.mira Project Header File 
 
*.rad Header file containing the measurement parameter for the channel, one for each 

channel 
 
*.rd3 Binary file containing raw data, one for each channel 
 
*.cfa Channel configuration file, containing the selected firing sequence for the 

measurement. 
*.cfd Channel order file, containing the position of the different channels in the array.  
 
*.cor GPS coordinates 
 
*.pdt Exact wheel and time positions for every trace. 
 

Format: <wheel position> <time position>  
 
*.tsn Exact time position from Total Station (only Leica). 

 
Format: <trace number><TAB><time from total station> 
 

For the files, besides the radar data files, the following naming convention is used (files saved in the 
project catalog): 
 
<project name>_GNN.pos.raw      - raw position files for every tie-in-point; 
 
FCODES.TXT.raw           - raw codes for rSlicer file; 
 
<swath name>.cfa                    - channels configuration for this swath; 
 
<swath name>.cfb                     - chanels order for this swath; 
 
<swath name>.mrk                - marker file; 
 
<first profile name>.cor          - raw GPS file; 
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Files for rSlicer 
 
For rSlicer the following data structure is applied and automatically created: 
 
All files are situated in the directory with name = <Project Name_rSlicer> 
 
<Project Name>_<Measurement number>.rad   Special header; 
<Project Name>_<Measurement number>.rd3   Data (all channels in one file); 
<Project Name>_<Measurement number>_G01.pos             Positions from GPS or Total Station 
Lines_G01.pos     Line features 
Points_G01.pos     Point features 
Tie_G01.pos    ..Tie in points 
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Appendix 1 
_______________________________________________________________________ 

 
This appendix covers the available filters in the 
MIRASoft filter manager. The filters that have settings 
that need to be set have a dialog connected to them. 
This dialog can be called from the Filter Manager and 
is shown in each filter description. Common to all 
filter dialogs is the trace window that shows the 
filtered trace. The trace window is updated when 
there is a change in the filter settings.  

 
 
Which filter to use is depending on the application and the quality of the radar image. A filter very 
useful for some applications can be useless in others. The knowledge and experience of the user 
often determines the time it takes to produce a useful image. A general recommendation is to start 
with DC filter and Gain. Below the available filters are listed and also if they are always, often, seldom 
or very seldom used in common GPR applications.   
 
Always used: DC-shift 
 
Often used: Delete Mean Trace, FIR, Time Gain  
 
Seldom used: Custom Gain, Moving Average, Moving Median, Threshold 
 
Very seldom used: Average, Median, AGC, Triangular FIR, HFIR 
 
 
Automatic gain control AGC 
This filter attempts to adjust the gain of 
each trace by equalizing the mean 
amplitudes observed in a sliding time 
window. A short window gives a more 
pronounced effect, the extreme of 
which would a one-sample window, 
which would cause all amplitudes to be 
equal. The other extreme would be a 
time window of the same length as the 
trace. This would have no effect on the 
trace. After equalization a constant 
multiplier is applied to the trace to 
make the resulting amplitudes 
reasonable.  
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Average 
The Average filter calculates a mean 
over a given number of samples and 
traces. The sample in the middle of the 
grid is replaced by the average value. . 
This filter acts as a simple 2D-lowpass 
filter and gives a softer picture. 
 

 
 
 
Custom Gain  
An amplifying filter where the 
gain factor is given manually for 
32 different sections of the 
trace.  
 

 
 
 
DC-Filter 
There is often a constant offset in the 
amplitude of the registered trace, this is known 
as the DC level or the DC offset. This filter 
removes the DC component from the data. The 
DC component is individually calculated and 
removed for each trace. 
 
In the dialog the sample interval on which the 
DC component is calculated is specified. 
Values for the start and end samples can be 
entered in the edit boxes or by click-dragging 
in the trace view. The sample interval is shown 
as a red area in the trace view. 
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Delete mean trace 
This filter is used to remove horizontal 
and nearly horizontal features in the 
radargram by subtracting a calculated 
mean trace from all traces, sample by 
sample. The mean trace can be 
calculated for the whole profile or for a 
specified section of the profile. 

 
 
FIR 
A quick band-pass filter, working with a 
combination of two boxcar (averaging) filters. 
The filter is run in two stages. First the lower 
frequencies are attenuated by  subtracting 
the average in the longer boxcar from the 
raw data at the centre of the boxcar. Then 
the higher frequencies are attenuated by 
replacing each sample with the average 
calculated in the shorter boxcar.  
 
Both boxes calculate along the whole trace.   

 
 
HFIR 
The HFIR filter functions as the FIR filter, 
but the filter runs along the profile - not 
along the trace. The filter is a spatial 
band-pass filter and its effect is similar to 
that of the background removal filter 

 
 
Median 
The Median filter functions as the 
Average filter, but instead of the mean 
value a median value is used. It removes 
spikes in the data efficiently while not 
blurring the image quite as much as the 
average filter does.  
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Moving average 
This filter takes the average as calculated 
by the average filter described above and 
subtracts it from the sample at the centre 
of the filter. Its effect is that of a simple 
2D high-pass filter. 
 
 
Moving median 
As the Moving average filter, but with the 
median value instead of the average.  
 
 

 
 
Threshold 
All samples with a value below the 
threshold are set to zero.  
 
 

 
 
Time-Gain Filter 
The Time-Gain filter applies a time-
varying gain to compensate for 
amplitude loss due to spreading and 
attenuation. The trace is multiplied by a 
gain function combining linear and an 
exponential gain, with coefficients set 
by the user. In the Time-Gain dialog, 
there is one trace window and one gain 
window. The trace window shows a 
filtered trace and the gain window 
shows the gain function applied.   
The red line in the trace window indicates the start of the filter (before this point the gain of the filter is 
unity). 
 
Triangular FIR  
The Triangular FIR filter functions as the 
FIR filter, but instead of using boxcar 
averages it uses averages in symmetrical 
triangular windows.  
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